Joomla have announced that they will no longer be supporting Joomla 2.5 from the end of December 2014. That means that all current Joomla 2.5 sites will no longer receive new updates and bug fixes.

How will this effect you? Your website won’t suddenly stop working but it will not get any new updates and security patches. Your site will continue to function as long as it has not been hacked. Unfortunately there are hackers out there that are constantly looking at ways to hack into your site and abuse the site information and server powers. The longer you leave your site before updating the more chance you will have of becoming a victim of these hackers.

Existing Joomla websites should be upgraded to the latest version of Joomla 3.3 (at time of writing). The upgrade from 2.5 to 3.3 is not as major an upgrade as moving from 1.5 but still requires some planning to maintain full functionality.

All components and plunging need to be checked that they are compatible with Joomla 3.3 and all updated installed. Most template developers already have versions of their templates that are compatible with Joomla 3.3.

Before upgrading we would recommend that you take a complete backup of your website and where possible create a mirror website to perform the upgrade on to make sure everything is working correctly and then replace your original site with the newly updated site.

Wicko Design and perform this backup and upgrade for you. Please contact us for more information.

You might like also

FREE SEO audit

Get a FREE SEO audit of your site and see how it well it is ranked by Google.

Subscribe here

Website Enquiry

Need a new website or just want to update an existing one.

Enquire here

News and advice

Sign up to get our regular email which contains the latest news and advice


Receive HTML?
catchme refresh

Joomla Extensions powered by Joobi